KF360 Pre Deployment - Knowledge Base

Introduction

 

This document details the minimum system requirements for Korn Ferry's survey platform: https://surveys.kornferry.com.

 

Please involve your IT department to ensure that the requirements are met.  We recommend a three step approach prior to launching surveys:

Step 1:
  • 3 Weeks Prior to Launch
  • Ensure our web pages are not cached by your servers, and that emails sent by our platform can be received.
Step 2:
  • 2 Weeks prior to launch
  • Ensure your computers meet the minimum requirements.
Step 3:
  • 1 Week prior to launch
  • Complete a test survey.

For very small projects step 3 may be sufficient, but for any medium or large projects all steps are highly recommended. If using our products in multiple locations or globally, you may want to involve IT from more than one region.

 

Step 1: Caching and Whitelisting

1 Disable caching

Disable caching of web pages from surveys.kornferry.com.

2 Whitelist our domains and host names

The following domains and/or host names should be whitelisted:
  • kornferry.com
  • assessments.kfproducts.com
  • assessments-launch.kfproducts.com
  • j735yqg24g.execute-api.us-east-1.amazonaws.com

 OR

3 Whitelist our e-mail addresses

If domains cannot be whitelisted, the following e-mail addresses should be whitelisted or added to a 'trusted' list:

  • The e-mail address of your Korn Ferry account manager sending out e-mails
  • haysurveys@kornferry.com
  • pathfinder@kornferry.com
  • diagnostics@kornferry.com

4 Whitelist our IP addresses

Depending on your network configuration, it may also be necessary to whitelist the following IP addresses: 

  • 40.80.144.17
  • 23.101.137.213
  • 52.151.8.123

  

Step 2: Minimum requirements

1 Browsers

Our survey site is tested in the following browsers:

  • Internet Explorer 11
  • Firefox (current or major previous versions)
  • Google Chrome (current or major previous versions)

2 JavaScript

JavaScript must be enabled in your browser.

To enable JavaScript in Internet Explorer:

  • Click "Tools" à "Internet Options"
  • Select the Security Tab
  • Select “Internet” zone and click on the “Custom Level” button
  • Scroll down to "Scripting"
  • Check the "Enable" radio button under “Active Scripting” heading
  • Click OK to save your preference.

To enable JavaScript in Firefox:

  • Click "Tools" à "Options"
  • Select the Content Tab
  • Check "Enable JavaScript" box
  • Check "Enable Java " box
  • Click OK to save your preference.

3 Cookies

Cookies must be enabled.

To enable cookies in Internet Explorer:

  • Click "Tools" à "Internet Options"
  • Select the Privacy Tab
  • Click “Sites”
  • Add kornferry.com and click “Allow” to allow all cookies
  • Click OK to save your preference.

To enable cookies in Firefox:

  • Click "Tools" à "Options"
  • Select the Privacy Panel
  • Verify that “Remember history” is selected
  • Your IT department might setup custom cookie handling by selecting “Use custom settings for history”. Please contact your IT department for further guidance.
  • Click OK to save your preference.

4 Pop-ups

Pop-ups must be enabled.

Note: Some security software and toolbars may also block pop-ups.


To enable pop-ups in Internet Explorer:

  • Click the Gear button in the top right hand corner of the screen.
  • Click "Internet Options" à"Privacy"
  • Uncheck the box to the left of "Turn on Pop Up Blocker" option
  • Hit Apply and OK

To enable pop-ups in Firefox:

  • Click the Menu button in the top right hand corner of the screen.
  • Choose "Options" à "Content" panel
  • Below Pop-ups uncheck the box next to "Block pop-up windows".

To enable pop-ups in Google Chrome:

  • Click the Menu button in the top right hand corner of the screen.
  • Click "Settings". At the bottom, click " Show advanced settings".
  • Under "Privacy", click "Content settings".
  • Under "Pop-ups", select an option: "Allow all sites to show pop-ups" and hit "Finished".

5 Flash player (e-learning only)

Some of Korn Ferry's e-learning modules require Adobe Flash Player. This plug-in is preloaded in many browsers. If not, the browser often installs automatically in a few seconds.

The module are compatible with the following Flash versions:

  • Flash 8 (excluding 8.0.24.0 which has a known bug)
  • Flash 9 (excluding 9.0.16.0 which has a known bug)
  • Flash 10

You can install the latest version here: www.adobe.com/products/flashplayer/

Automatic installation or upgrade of the player will not happen if the user does not have administration rights on their computer.

6 MAC OS (e-learning only)

Korn Ferry's e-learning modules will work in Mac OS X 10.6 and above. However, given a history of Mac-Flash compatibility issues, we generally suggest using windows-based computers where possible. Unfortunately we will not be able to troubleshoot MAC related queries in depth.

 

7 IE9 (e-learning only)

Our new Styles & Climate 2.0 e-learning modules (Your Leadership Styles feedback, Your Climate feedback & Practitioner Update) are built using the latest HTML5 technology.

  • These modules are compatible with Internet Explorer 11.
  • The e-learning modules will not work in Firefox as this browser doesn’t fully support HTML5.

 

Step 3 - Completing a test survey

A critical step to ensure everything is working properly is to complete a test survey (and/or e-learning modules, as appropriate). Your account manager will set you up with a test account.

Your IT contact (ideally) should complete and submit the test survey to see if they can spot any potential issues.